现在位置首页 / 项目实战 /正文

win7/8 php环境配置及插件下载完整说明

作者: IT小兵 | 2015年7月29日| 热度:℃ | 评论: |参与:

最近捣鼓php(拍黄片吗?),win7 /8环境开发,centos环境部署,但是在windows平台配置php潜规则还是很多。

这里整理一下步骤。

1、下载php

到官方http://www.php.net/   下载php环境。这里需要注意,下载的版本问题。

他有很多版本

VC11 x86 Thread Safe

VC11 x64 Non Thread Safe 

VC11 x64 Thread Safe

VC6 版本是使用 Visual Studio 6 编译器编译的,如果你是在windows下使用Apache+PHP的,请选择VC6版本。

VC9 版本是使用 Visual Studio 2008 编译器编译的,如果你是在windows下使用IIS+PHP的,请选择VC9版本。

Non Thread Safe就是非线程安全,在执行时不进行线程(Thread)安全检查;
Non Thread Safe 是线程安全,执行时会进行线程(Thread)安全检查,以防止有新要求就启动新线程的 CGI 执行方式而耗尽系统资源;

Windows下的PHP 主要有两种执行方式:ISAPI 和 FastCGI。

      ISAPI 执行方式是以 DLL 动态库的形式使用,可以在被用户请求后执行,在处理完一个用户请求后不会马上消失,所以需要进行线程安全检查,这样来提高程序的执行效率,所以如果是以 ISAPI 来执行 PHP,建议选择 Thread Safe 版本;

      FastCGI 执行方式是以单一线程来执行操作,所以不需要进行线程的安全检查,除去线程安全检查的防护反而可以提高执行效率,所以,如果是以 FastCGI 来执行 PHP,建议选择 Non Thread Safe 版本。

      官方并不建议你将Non Thread Safe 应用于生产环境。


win7/8 我使用的VC11 x64 Non Thread Safe 


2、解压到c盘目录下面,下面来安装插件ext

php所有官方的插件都可以在这里找到。http://pecl.php.net/package-stats.php 大家不要乱下载。

比如memcache,可以在这里:http://pecl.php.net/package/memcache/3.0.8/windows 

 还是下载版本问题,这个问题困扰我很久。你下载版本不对,在phpinfo()就不会出现memecache插件。

详细说明参考

[php tools for visual studio php环境及调试xdebug的配置]


大家直接下载我配置好的php,支持数据库mysql、memcache。

链接:http://pan.baidu.com/s/1sj61Dcp   密码:lq79

点击阅读本文所属分类的更多文章: 项目实战 。和高手一起交流:346717337
友荐云推荐

未注明转发、原文均为本站原创。分享本文请注明 原文链接

给您更多信息和帮助

在这里您可以找到更多:

技术交流群:346717337 Jquery插件交流

投稿:suchso@vip.qq.com

承接:企业网站门户/微网站/微商城/CMS系统/微信公众号运营/业务咨询

抢天猫双11红包
推荐使用阿里云服务器
echarts教程系列
本月最热文章

微信扫一扫,徜徉悠嘻网,您的休闲乐园

微信公众号:快乐每一天

随机文章
标签

技术交流群:346717337

投稿:suchso@vip.qq.com

专业专注:企业网站门户/微网站/微商城/CMS系统/微信公众号运营/付费问题咨询